<!DOCTYPE html><html lang="en" prefix="og=https://ogp.me/ns#" itemscope="" itemType="https://schema.org/WebPage"><head><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/icomoon.ttf" type="font/ttf" crossorigin="anonymous"/><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/351C86_0_0.woff2" type="font/woff2" crossorigin="anonymous"/><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/351C86_1_0.woff2" type="font/woff2" crossorigin="anonymous"/><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/351C86_2_0.woff2" type="font/woff2" crossorigin="anonymous"/><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/351C86_3_0.woff2" type="font/woff2" crossorigin="anonymous"/><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/351C86_4_0.woff2" type="font/woff2" crossorigin="anonymous"/><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/LyonText-Bold-Web.woff2" type="font/woff2" crossorigin="anonymous"/><link rel="preload" as="font" href="https://static-redesign.cnbcfm.com/dist/LyonText-Regular-Web.woff2" type="font/woff2" crossorigin="anonymous"/><meta name="format-detection" content="telephone=no"/><style type="text/css">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</style><script type="text/javascript">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</script><link rel="preload" as="script" href="https://sb.scorecardresearch.com/beacon.js"/><title itemProp="name">Thursday Wall Street calls: Amazon, Spotify, Teladoc, Meta, Boeing </title><meta name="viewport" content="initial-scale=1.0, width=device-width"/><meta http-equiv="X-UA-Compatible" content="IE=Edge"/><meta property="AssetType" content="cnbcnewsstory"/><meta property="pageNodeId" content="107052677"/><meta itemProp="description" name="description" content="Here are the biggest calls on Wall Street on Thursday."/><link rel="canonical" href="https://www.cnbc.com/2022/04/28/thursday-wall-street-calls-amazon-spotify-teladoc-meta-boeing-.html"/><link rel="icon" type="image/png" href="/favicon.ico"/><meta property="og:type" content="article"/><meta property="og:title" content="Here are Thursday&#x27;s biggest analyst calls of the day: Amazon, Spotify, Teladoc, Meta, Boeing &amp; more"/><meta property="og:description" content="Here are the biggest calls on Wall Street on Thursday."/><meta property="og:url" content="https://www.cnbc.com/2022/04/28/thursday-wall-street-calls-amazon-spotify-teladoc-meta-boeing-.html"/><meta property="og:site_name" content="CNBC"/><meta itemProp="dateCreated" content="2022-04-28T12:32:04+0000"/><meta itemProp="dateModified" content="2022-04-28T12:32:04+0000"/><meta itemProp="lastReviewed" content="2022-04-28T12:32:04+0000"/><meta itemProp="inLanguage" content="en-US"/><meta itemProp="sourceOrganization" content="CNBC"/><meta property="og:image" itemProp="image" content="https://image.cnbcfm.com/api/v1/image/107015691-16449485412022-02-15t180558z_1872005357_rc2iks9owpqo_rtrmadp_0_boeing-787-faa.jpeg?v=1644948618&amp;w=1920&amp;h=1080"/><meta name="twitter:image:src" content="https://image.cnbcfm.com/api/v1/image/107015691-16449485412022-02-15t180558z_1872005357_rc2iks9owpqo_rtrmadp_0_boeing-787-faa.jpeg?v=1644948618&amp;w=1920&amp;h=1080"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@CNBC"/><meta name="twitter:url" content="https://www.cnbc.com/2022/04/28/thursday-wall-street-calls-amazon-spotify-teladoc-meta-boeing-.html"/><meta name="twitter:title" content="Here are Thursday&#x27;s biggest analyst calls of the day: Amazon, Spotify, Teladoc, Meta, Boeing &amp; more"/><meta name="twitter:description" content="Here are the biggest calls on Wall Street on Thursday."/><meta name="twitter:creator" content="@CNBC"/><meta property="article:publisher" content="https://www.facebook.com/cnbc"/><meta property="article:published_time" content="2022-04-28T12:32:04+0000"/><meta property="article:modified_time" content="2022-04-28T12:32:04+0000"/><meta itemProp="contentRating" content="NR"/><meta name="news_keywords" content="Pro: Short-term,Freshpet Inc,Walt Disney Co,Meta Platforms Inc,Spotify Technology SA,Fifth Third Bancorp,Allstate Corp,Hertz Global Holdings Inc,3M Co,Boeing Co,Ford Motor Co,Amazon.com Inc,Teladoc Health Inc,EVGO Inc.,Investment strategy,Breaking News: Markets,Markets,Investment strategy,business news"/><meta itemProp="keywords" name="keywords" content="Pro: Short-term,Freshpet Inc,Walt Disney Co,Meta Platforms Inc,Spotify Technology SA,Fifth Third Bancorp,Allstate Corp,Hertz Global Holdings Inc,3M Co,Boeing Co,Ford Motor Co,Amazon.com Inc,Teladoc Health Inc,EVGO Inc.,Investment strategy,Breaking News: Markets,Markets,Investment strategy,business news"/><meta itemProp="specialty" content="Pro: Short-term,Freshpet Inc,Walt Disney Co,Meta Platforms Inc,Spotify Technology SA,Fifth Third Bancorp,Allstate Corp,Hertz Global Holdings Inc,3M Co,Boeing Co,Ford Motor Co,Amazon.com Inc,Teladoc Health Inc,EVGO Inc.,Investment strategy,Breaking News: Markets,Markets,Investment strategy"/><meta name="tp:PreferredRuntimes" content="universal"/><meta name="tp:PreferredFormats" content="M3U,MPEG4"/><meta name="tp:initialize" content="false"/><meta name="apple-itunes-app" content="app-id=398018310" app-argument="//www.cnbc.com/id/104671274"/><meta property="al:ios:app_name" content="CNBC Business News and Finance"/><meta property="al:ios:app_store_id" content="398018310"/><meta itemProp="primaryImageOfPage" content="https://image.cnbcfm.com/api/v1/image/107015691-16449485412022-02-15t180558z_1872005357_rc2iks9owpqo_rtrmadp_0_boeing-787-faa.jpeg?v=1644948618"/><meta name="parsely-metadata" content="{&quot;nodeid&quot;:107052677,&quot;originalImage&quot;:&quot;https://image.cnbcfm.com/api/v1/image/107015691-16449485412022-02-15t180558z_1872005357_rc2iks9owpqo_rtrmadp_0_boeing-787-faa.jpeg?v=1644948618&quot;}"/><meta name="robots" content="max-image-preview:large"/><script type="application/ld+json">{"@context":"https://schema.org","@type":"NewsArticle","description":"Here are the biggest calls on Wall Street on Thursday.","speakable":{"@type":"SpeakableSpecification","xpath":["/html/head/title","/html/head/meta[@name=\"description\"]/@content","//div[contains(@class, \"group\")][1]/p"]},"mainEntityOfPage":"https://www.cnbc.com/2022/04/28/thursday-wall-street-calls-amazon-spotify-teladoc-meta-boeing-.html","url":"https://www.cnbc.com/2022/04/28/thursday-wall-street-calls-amazon-spotify-teladoc-meta-boeing-.html","headline":"Here are Thursday's biggest analyst calls of the day: Amazon, Spotify, Teladoc, Meta, Boeing & more","dateCreated":"2022-04-28T12:32:04+0000","datePublished":"2022-04-28T12:32:04+0000","dateModified":"2022-04-28T12:32:04+0000","author":[{"@type":"Person","name":"Michael Bloom","url":"https://www.cnbc.com/michael-bloom/"}],"publisher":{"@type":"Organization","name":"CNBC","url":"https://www.cnbc.com/","logo":{"@type":"ImageObject","url":"https://sc.cnbcfm.com/applications/cnbc.com/staticcontent/img/cnbc-hdr-logo2.png","width":360,"height":60},"sameAs":["https://www.facebook.com/cnbc","https://www.instagram.com/cnbc","https://www.linkedin.com/company/cnbc","https://twitter.com/cnbc"]},"articleSection":"PRO Home","keywords":["cnbc","Premium","Articles","Pro: Short-term","Freshpet Inc","Walt Disney Co","Meta Platforms Inc","Spotify Technology SA","Fifth Third Bancorp","Allstate Corp","Hertz Global Holdings Inc","3M Co","Boeing Co","Ford Motor Co","Amazon.com Inc","Teladoc Health Inc","EVGO Inc.","Investment strategy","Breaking News: Markets","Markets","Investing","U.S. Markets","PRO Home","CNBC Pro","Pro: Street Calls ","source:tagname:CNBC US Source"],"image":{"@type":"ImageObject","url":"https://image.cnbcfm.com/api/v1/image/107015691-16449485412022-02-15t180558z_1872005357_rc2iks9owpqo_rtrmadp_0_boeing-787-faa.jpeg?v=1644948618","width":3500,"height":2333},"thumbnailUrl":"https://image.cnbcfm.com/api/v1/image/107015691-16449485412022-02-15t180558z_1872005357_rc2iks9owpqo_rtrmadp_0_boeing-787-faa.jpeg?v=1644948618&w=720&h=405","isAccessibleForFree":false,"hasPart":{"isAccessibleForFree":false,"@type":"WebPageElement","cssSelector":"ArticleGate-proGate"}}</script><meta property="article:section" content="Pro: Street Calls "/><meta property="article:author" content="https://www.facebook.com/CNBC"/><meta name="author" content="Michael Bloom"/><meta property="article:opinion" content="false"/><meta property="article:tag" content="Pro: Short-term"/><meta property="article:tag" content="Freshpet Inc"/><meta property="article:tag" content="Walt Disney Co"/><meta property="article:tag" content="Meta Platforms Inc"/><meta property="article:tag" content="Spotify Technology SA"/><meta property="article:tag" content="Fifth Third Bancorp"/><meta property="article:tag" content="Allstate Corp"/><meta property="article:tag" content="Hertz Global Holdings Inc"/><meta property="article:tag" content="3M Co"/><meta property="article:tag" content="Boeing Co"/><meta property="article:tag" content="Ford Motor Co"/><meta property="article:tag" content="Amazon.com Inc"/><meta property="article:tag" content="Teladoc Health Inc"/><meta property="article:tag" content="EVGO Inc."/><meta property="article:tag" content="Investment strategy"/><meta property="article:tag" content="Breaking News: Markets"/><meta property="article:tag" content="Markets"/><meta property="article:tag" content="Investment strategy"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/main-00264b0167f266e226ba.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/vendors~AcornsGlobalNav~CNBCGlobalNav~EpisodePage~MakeItGlobalNav~components-PcmModule-LiveTV~compon~b4bd0269-f55b44ed9fec01155b54.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/vendors~AcornsGlobalNav~CNBCGlobalNav~MakeItGlobalNav-f3b6929c9b2301bc66df.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/AcornsGlobalNav~CNBCGlobalNav~MakeItGlobalNav~SelectGlobalNav-04288154fc0d315e2bfb.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/AcornsGlobalNav~CNBCGlobalNav~MakeItGlobalNav-e0836e872532a471d609.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/CNBCGlobalNav-a668c1c56da6866fd982.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-ArticleHeader-1dd9b0fc2fbea31855e7.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-ArticleInlineMedia-546d7b8403ba3fefcbff.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/ArticleInlineMediaPremium-dfdd07f5ec38428051eb.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-KeyPoints-b081dfd730b0a38ea09f.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-ArticleBody-1884c388b2fe87f029a5.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-ArticleRelatedVideo-8fb9115713b4b16dbf29.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-WatchLiveRightRail-693e59b021a144b1e3ca.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-LiveEventModule-cb85a54d27c58cf23ddd.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-Ads-BoxRail-313502087ed2d8799545.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-PcmModule-TransporterSection-537ace865e5ec63f6063.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-Column~components-PcmModule-DynamicContentFeedContainer~components-PcmModule-MarketNewsTa~6ff6925b-6b684b293f53ee136c11.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-Column~components-PcmModule-DynamicContentFeedContainer-c7a6c4ccb57bb0e19aec.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-Column-fc7dba22c24a336ac613.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-shared-Card-faf5eed7084fcde854bf.js"/><link rel="preload" as="script" href="https://static-redesign.cnbcfm.com/dist/components-Footer-CNBCFooter-deedd39a1d7fdddc694e.js"/></head><body><div><!-- Comscore Identifier: comscorekw=PRO_Home_CNBC_Pro --></div><div id="root"><div class="App-containerClick"><div id="BrandPageWrapper" class="cnbcBrand"><div class="JumpLink-container"><a href="#MainContent" class="JumpLink-link">Skip Navigation</a></div><header class="CNBCGlobalNav-container" id="GlobalNavigation" data-test="GlobalNavigation" data-analytics="RegularArticle-GlobalNavigation"><div class="CountdownClock-countdownContainer"><div id="GlobalNavigation-CountdownClock" class="CountdownClock-container" data-module="mps-slot"></div></div><div class="CNBCGlobalNav-globalNavigation"><div class="CNBCGlobalNav-gridContainer"><div class="CNBCGlobalNav-wrapper"><div class="branding-menu-brandingMenu"><a href="//www.cnbc.com/" class="branding-menu-logo"><img src="data:image/svg+xml;base64,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" alt="logo" class="branding-menu-logo"/></a><ul class="branding-menu-watchLive"><li><a href="/live-tv/">watch<span>live</span></a></li></ul></div><div class="CNBCGlobalNav-desktopNavMenu"><div class="nav-menu-navMenu " id="nav-menu"><button class="nav-menu-desktopHamburger nav-menu-button" aria-label="Open Navigation Menu"><span class="icon-menu"></span></button><a href="/" class="nav-menu-logoContainer"><img src="data:image/svg+xml;base64,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" class="nav-menu-logo" alt="logo"/></a><div class="nav-menu-mainLinks"><div class="nav-menu-mainLinksWrapperStart nav-menu-mainLinksWrapper"><div class=" nav-menu-navLinks"><div class="nav-menu-primaryLink markets"><a href="/markets/" class="nav-menu-button"><span class="icon-markets"></span><span class="nav-menu-buttonText">Markets</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="Pre-Markets"><a href="/pre-markets/" class="nav-menu-subLink" tabindex="-1">Pre-Markets</a></li><li data-text="U.S. Markets"><a href="/us-markets/" class="nav-menu-subLink" tabindex="-1">U.S. Markets</a></li><li data-text="Currencies"><a href="/currencies/" class="nav-menu-subLink" tabindex="-1">Currencies</a></li><li data-text="Cryptocurrency"><a href="/cryptocurrency/" class="nav-menu-subLink" tabindex="-1">Cryptocurrency</a></li><li data-text="Futures &amp; Commodities"><a href="/futures-and-commodities/" class="nav-menu-subLink" tabindex="-1">Futures &amp; Commodities</a></li><li data-text="Bonds"><a href="/bonds/" class="nav-menu-subLink" tabindex="-1">Bonds</a></li><li data-text="Funds &amp; ETFs"><a href="/funds-and-etfs/" class="nav-menu-subLink" tabindex="-1">Funds &amp; ETFs</a></li></ul></div><div class="nav-menu-primaryLink business_news"><a href="/business/" class="nav-menu-button"><span class="icon-news"></span><span class="nav-menu-buttonText">Business</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="Economy"><a href="/economy/" class="nav-menu-subLink" tabindex="-1">Economy</a></li><li data-text="Finance"><a href="/finance/" class="nav-menu-subLink" tabindex="-1">Finance</a></li><li data-text="Health &amp; Science"><a href="/health-and-science/" class="nav-menu-subLink" tabindex="-1">Health &amp; Science</a></li><li data-text="Media"><a href="/media/" class="nav-menu-subLink" tabindex="-1">Media</a></li><li data-text="Real Estate"><a href="/real-estate/" class="nav-menu-subLink" tabindex="-1">Real Estate</a></li><li data-text="Energy"><a href="/energy/" class="nav-menu-subLink" tabindex="-1">Energy</a></li><li data-text="Climate"><a href="/climate/" class="nav-menu-subLink" tabindex="-1">Climate</a></li><li data-text="Transportation"><a href="/transportation/" class="nav-menu-subLink" tabindex="-1">Transportation</a></li><li data-text="Industrials"><a href="/industrials/" class="nav-menu-subLink" tabindex="-1">Industrials</a></li><li data-text="Retail"><a href="/retail/" class="nav-menu-subLink" tabindex="-1">Retail</a></li><li data-text="Wealth"><a href="/wealth/" class="nav-menu-subLink" tabindex="-1">Wealth</a></li><li data-text="Life"><a href="/life/" class="nav-menu-subLink" tabindex="-1">Life</a></li><li data-text="Small Business"><a href="/small-business/" class="nav-menu-subLink" tabindex="-1">Small Business</a></li></ul></div><div class="nav-menu-primaryLink investing"><a href="/investing/" class="nav-menu-button"><span class="icon-investing"></span><span class="nav-menu-buttonText">Investing</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="Invest In You"><a href="/invest-in-you/" class="nav-menu-subLink" tabindex="-1">Invest In You</a></li><li data-text="Personal Finance"><a href="/personal-finance/" class="nav-menu-subLink" tabindex="-1">Personal Finance</a></li><li data-text="Fintech"><a href="/fintech/" class="nav-menu-subLink" tabindex="-1">Fintech</a></li><li data-text="Financial Advisors"><a href="/financial-advisors/" class="nav-menu-subLink" tabindex="-1">Financial Advisors</a></li><li data-text="Options Action"><a href="/options-action/" class="nav-menu-subLink" tabindex="-1">Options Action</a></li><li data-text="ETF Street"><a href="/etf-street/" class="nav-menu-subLink" tabindex="-1">ETF Street</a></li><li data-text="Buffett Archive"><a href="https://buffett.cnbc.com" class="nav-menu-subLink" target="_blank" tabindex="-1">Buffett Archive</a></li><li data-text="Earnings"><a href="/earnings/" class="nav-menu-subLink" tabindex="-1">Earnings</a></li><li data-text="Trader Talk"><a href="/trader-talk/" class="nav-menu-subLink" tabindex="-1">Trader Talk</a></li></ul></div><div class="nav-menu-primaryLink tech"><a href="/technology/" class="nav-menu-button"><span class="icon-tech"></span><span class="nav-menu-buttonText">Tech</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="Cybersecurity"><a href="/cybersecurity/" class="nav-menu-subLink" tabindex="-1">Cybersecurity</a></li><li data-text="Enterprise"><a href="/enterprise/" class="nav-menu-subLink" tabindex="-1">Enterprise</a></li><li data-text="Internet"><a href="/internet/" class="nav-menu-subLink" tabindex="-1">Internet</a></li><li data-text="Media"><a href="/media/" class="nav-menu-subLink" tabindex="-1">Media</a></li><li data-text="Mobile"><a href="/mobile/" class="nav-menu-subLink" tabindex="-1">Mobile</a></li><li data-text="Social Media"><a href="/social-media/" class="nav-menu-subLink" tabindex="-1">Social Media</a></li><li data-text="CNBC Disruptor 50"><a href="/cnbc-disruptors/" class="nav-menu-subLink" tabindex="-1">CNBC Disruptor 50</a></li><li data-text="Tech Guide"><a href="/tech-guide/" class="nav-menu-subLink" tabindex="-1">Tech Guide</a></li></ul></div><div class="nav-menu-primaryLink politics"><a href="/politics/" class="nav-menu-button"><span class="icon-politics"></span><span class="nav-menu-buttonText">Politics</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="White House"><a href="/white-house/" class="nav-menu-subLink" tabindex="-1">White House</a></li><li data-text="Policy"><a href="/policy/" class="nav-menu-subLink" tabindex="-1">Policy</a></li><li data-text="Defense"><a href="/defense/" class="nav-menu-subLink" tabindex="-1">Defense</a></li><li data-text="Congress"><a href="/congress/" class="nav-menu-subLink" tabindex="-1">Congress</a></li><li data-text="Equity and Opportunity"><a href="/equity-opportunity/" class="nav-menu-subLink" tabindex="-1">Equity and Opportunity</a></li></ul></div><div class="nav-menu-primaryLink cnbc_tv"><a href="/tv/" class="nav-menu-button"><span class="icon-cnbctv"></span><span class="nav-menu-buttonText">CNBC TV</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="Live TV"><a href="/live-tv" class="nav-menu-subLink" tabindex="-1">Live TV</a></li><li data-text="Live Audio"><a href="/live-audio/" class="nav-menu-subLink" tabindex="-1">Live Audio</a></li><li data-text="Business Day Shows"><a href="/business-day/" class="nav-menu-subLink" tabindex="-1">Business Day Shows</a></li><li data-text="The News with Shepard Smith"><a href="/the-news-with-shepard-smith/" class="nav-menu-subLink" tabindex="-1">The News with Shepard Smith</a></li><li data-text="Entertainment Shows"><a href="/primetime-shows/" class="nav-menu-subLink" tabindex="-1">Entertainment Shows</a></li><li data-text="Full Episodes"><a href="/live-tv/full-episodes/" class="nav-menu-subLink" tabindex="-1">Full Episodes</a></li><li data-text="Latest Video"><a href="/latest-video/" class="nav-menu-subLink" tabindex="-1">Latest Video</a></li><li data-text="Top Video"><a href="/top-video/" class="nav-menu-subLink" tabindex="-1">Top Video</a></li><li data-text="CEO Interviews"><a href="/video-ceo-interviews/" class="nav-menu-subLink" tabindex="-1">CEO Interviews</a></li><li data-text="CNBC Documentaries"><a href="/documentaries/" class="nav-menu-subLink" tabindex="-1">CNBC Documentaries</a></li><li data-text="CNBC Podcasts"><a href="/podcast/" class="nav-menu-subLink" tabindex="-1">CNBC Podcasts</a></li><li data-text="CNBC World"><a href="/features/" class="nav-menu-subLink" tabindex="-1">CNBC World</a></li><li data-text="Digital Originals"><a href="/digital-original/" class="nav-menu-subLink" tabindex="-1">Digital Originals</a></li><li data-text="Live TV Schedule"><a href="/live-tv/schedule/" class="nav-menu-subLink" tabindex="-1">Live TV Schedule</a></li></ul></div><div class="nav-menu-primaryLink watchlist"><a href="/watchlist/" class="nav-menu-button"><span class="icon-watchlist"></span><span class="nav-menu-buttonText">Watchlist</span></a></div><div class="nav-menu-primaryLink investing_club"><a href="/investingclub/" class="nav-menu-button"><span class="icon-investing_club"></span><span class="nav-menu-buttonText">Investing Club</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="Newsletter"><a href="/investingclub/newsletter/" class="nav-menu-subLink" tabindex="-1">Newsletter</a></li><li data-text="Morning Meeting"><a href="/investingclub/morning-meeting/" class="nav-menu-subLink" tabindex="-1">Morning Meeting</a></li><li data-text="Trade Alerts"><a href="/investingclub/cramer-trade-alert/" class="nav-menu-subLink" tabindex="-1">Trade Alerts</a></li><li data-text="Trust Portfolio"><a href="/investingclub/charitable-trust/" class="nav-menu-subLink" tabindex="-1">Trust Portfolio</a></li></ul></div><div class="nav-menu-primaryLink pro"><a href="/pro/" class="nav-menu-button"><span class="icon-pro"></span><span class="nav-menu-buttonText">PRO</span></a><ul class="nav-menu-subLinks" style="display:none"><li data-text="Pro News"><a href="/pro/news/" class="nav-menu-subLink" tabindex="-1">Pro News</a></li><li data-text="Pro Live"><a href="/pro/" class="nav-menu-subLink" tabindex="-1">Pro Live</a></li><li data-text="Subscribe"><a href="#" class="nav-menu-subLink" tabindex="-1">Subscribe</a></li><li data-text="Sign In"><a href="#" class="nav-menu-subLink" tabindex="-1">Sign In</a></li></ul></div><span class="nav-menu-proLockIcon"></span><div aria-hidden="true" class="nav-menu-navUnderline"></div><div aria-hidden="true" class="nav-menu-navDropdownWrap"></div><div class="nav-menu-primaryLink hamburger"><button class="nav-menu-hamburger nav-menu-button" aria-label="Open Navigation Menu"><span class="icon-menu"></span><span class="nav-menu-buttonText">Menu</span></button></div></div></div></div><div class="nav-menu-progressBarContainer"></div></div><div class="account-menu-accountMenu"><ul><li><a href="/make-it/" title="makeit">Make It<span class="icon-offsite-arrow"></span></a></li></ul><ul class="account-menu-editionMenu"><li class="AccountMenu-li"><a href="/?region=usa" class="account-menu-underlineLabel">USA</a></li><li class="AccountMenu-li"><a href="/world/">INTL</a></li></ul><ul class="account-menu-watchLive"><li><a href="/live-tv/">watch<span>live</span></a></li></ul></div></div><button class="SearchToggle-button SearchToggle-signinButton searchToggler analyticsSearchButton" aria-label="Search"><span>Search quotes, news &amp; videos</span><i class="icon-search" aria-hidden="true" data-analytics-id="cnbc-search-icon" data-analytics="cnbc-search-icon"></i></button><span></span><div class="CNBCGlobalNav-watchListContainer"><a href="/watchlist/">Watchlist</a></div><div class="SignInMenu-signInContainer"><div><div class="SignInMenu-signInMenu"><a href="#">SIGN IN</a></div></div></div></div></div></div><span></span></header><div class="CNBCGlobalNav-mobileNavMenu"><div class="nav-menu-navMenu " id="nav-menu"><button class="nav-menu-desktopHamburger nav-menu-button" aria-label="Open Navigation Menu"><span class="icon-menu"></span></button><a href="/" class="nav-menu-logoContainer"><img src="data:image/svg+xml;base64,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" class="nav-menu-logo" alt="logo"/></a><div class="nav-menu-mainLinks"><div class="nav-menu-mainLinksWrapperStart nav-menu-mainLinksWrapper"><div class=" nav-menu-navLinks"><div class="nav-menu-primaryLink markets"><a href="/markets/" class="nav-menu-button"><span class="icon-markets"></span><span class="nav-menu-buttonText">Markets</span></a></div><div class="nav-menu-primaryLink business_news"><a href="/business/" class="nav-menu-button"><span class="icon-news"></span><span class="nav-menu-buttonText">Business</span></a></div><div class="nav-menu-primaryLink investing"><a href="/investing/" class="nav-menu-button"><span class="icon-investing"></span><span class="nav-menu-buttonText">Investing</span></a></div><div class="nav-menu-primaryLink tech"><a href="/technology/" class="nav-menu-button"><span class="icon-tech"></span><span class="nav-menu-buttonText">Tech</span></a></div><div class="nav-menu-primaryLink politics"><a href="/politics/" class="nav-menu-button"><span class="icon-politics"></span><span class="nav-menu-buttonText">Politics</span></a></div><div class="nav-menu-primaryLink cnbc_tv"><a href="/tv/" class="nav-menu-button"><span class="icon-cnbctv"></span><span class="nav-menu-buttonText">CNBC TV</span></a></div><div class="nav-menu-primaryLink watchlist"><a href="/watchlist/" class="nav-menu-button"><span class="icon-watchlist"></span><span class="nav-menu-buttonText">Watchlist</span></a></div><div class="nav-menu-primaryLink investing_club"><a href="/investingclub/" class="nav-menu-button"><span class="icon-investing_club"></span><span class="nav-menu-buttonText">Investing Club</span></a></div><div class="nav-menu-primaryLink pro"><a href="/pro/" class="nav-menu-button"><span class="icon-pro"></span><span class="nav-menu-buttonText">PRO</span></a></div><span class="nav-menu-proLockIcon"></span><div aria-hidden="true" class="nav-menu-navUnderline"></div><div aria-hidden="true" class="nav-menu-navDropdownWrap"></div><div class="nav-menu-primaryLink hamburger"><button class="nav-menu-hamburger nav-menu-button" aria-label="Open Navigation Menu"><span class="icon-menu"></span><span class="nav-menu-buttonText">Menu</span></button></div></div></div></div><div class="nav-menu-progressBarContainer"></div></div></div><div class="BrandPageWrapper-liveAlertAd BrandPageWrapper-contentWrapper" role="main" id="MainContentContainer"><p id="MainContent" tabindex="-1"></p><div><div class="Regular Article PageBuilder-page"><div class="PageBuilder-pageWrapper"><div class="PageBuilder-containerWidth100 PageBuilder-pageRow"><div class="PageBuilder-col-full PageBuilder-col PageBuilder-article"></div></div><div class="PageBuilder-containerWidth100 PageBuilder-pageRow"><div class="PageBuilder-col-full PageBuilder-col PageBuilder-article"><div id="RegularArticle-ArticleHeader-2" data-test="articleHeader-0" data-analytics="RegularArticle-articleHeader-2-0"><header class="ArticleHeader-articleHeader" id="main-article-header"><div class="ArticleHeader-headerContentContainer"><div class="ArticleHeader-wrapperHeroNoImage ArticleHeader-wrapperHero ArticleHeader-wrapper ArticleHeader-wrapperNoImage"><a href="/pro/" class="ProPill-proPillLink" data-type="pro-button"><img class="ArticleHeader-proPill ProPill-proPill" src="data:image/svg+xml;base64,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" alt="CNBC Pro"/></a><div><h1 class="ArticleHeader-headline">Here are Thursday&#x27;s biggest analyst calls of the day: Amazon, Spotify, Teladoc, Meta, Boeing &amp; more</h1></div><div class="ArticleHeader-timeHidden"><time data-testid="published-timestamp" dateTime="2022-04-28T12:32:04+0000" itemProp="datePublished">Published Thu, Apr 28 2022<span class="ArticleHeader-datetimeDivider"></span>8:32 AM EDT</time></div></div><div class="ArticleHeader-authorAndShareInline"><div class="ArticleHeader-authorContainer ArticleHeader-authorContainerWithWatchLive"><div class="ArticleHeader-author"><div class="Author-author"><div class="Author-authorInfo"><div class="Author-authorNameAndSocial"><a href="https://www.cnbc.com/michael-bloom/" class="Author-authorName">Michael Bloom<span class="Author-authorUnderline"></span></a></div></div></div></div></div><span><a href="/live-tv/" class="WatchLive-container">WATCH LIVE</a></span></div></div></header></div></div></div><div class="PageBuilder-containerFluidWidths PageBuilder-pageRow"><div class="PageBuilder-col-9 PageBuilder-col PageBuilder-article"><div data-test="articleInlineMedia-0" data-analytics="RegularArticle-articleInlineMedia-3-0"></div><div data-test="articleBody-2" data-analytics="RegularArticle-articleBody-5-2"></div></div><div class="SidebarArticle-sidebar PageBuilder-sidebar" data-test="SidebarArticle"><div class="SidebarArticle-sticky" style="top:70px"><div><div class="LiveEventModule-container" id="Regular Article-LiveEventModule" data-analytics="Regular Article-LiveEventModule" data-analytics-id="Regular Article-LiveEventModule"><div class="LiveEventModule-eventDate"><a href="/pro/talks" class="LiveEventModule-headerLink"><h2 class="LiveEventModule-header">NEXT PRO TALK</h2></a><div class="EventDateTitle-remainingDate">4 Days Remaining</div><div class="LiveEventModule-date">Mon, May 2 2022 - 11:30am<div class="LiveEventModule-calendarContainer"><div class="LiveEventModule-proCalendar"><button class="LiveEventModule-proCalendar" id="add to calendar" data-analytics-id="add to calendar"><span class="LiveEventModule-proCalendarImg"></span>Add to Calendar</button></div></div></div></div><div class="LiveEventModule-eventTitle"><a href="/pro/talks"><img src="https://image.cnbcfm.com/api/v1/image/107052618-1651095107407-21742762_DIGITAL_CNBC_PRO_SLATE_MILKEN.png?v=1651095508" alt="thumbnail" class="LiveEventModule-thumbnail"/></a><a href="/pro/talks"><div class="LiveEventModule-headline LiveEventModule-headlineWithSpacing">CNBC PRO Talks: Special event with Brian Sullivan at the Milken Global Conference </div></a></div></div></div><div></div><div style="margin-top:0px"></div><div><div style="height:100%" class="lazyload-placeholder"></div></div></div></div></div><div class="PageBuilder-containerFluidWidths PageBuilder-pageRow"><div class="PageBuilder-col-9 PageBuilder-col PageBuilder-article"><div class="TransporterSection-transporterWrapper" id="RegularArticle-TransporterSection-12" data-test="transporterSection-0" data-analytics="RegularArticle-transporterSection-12-0"><section class="SectionWrapper-container" data-test="SectionWrapper"><header class="SectionWrapper-header"><span class="SectionWrapper-decoration" aria-hidden="true"></span><h2 class="SectionWrapper-title"><a href="https://www.cnbc.com/pro/street-calls/">More In Street Calls </a></h2></header><div class="SectionWrapper-content"><div class="Layout-layout" data-test="Layout"><div class="Column-squareLeadLeft " data-test="Column"><div class="Card-standardBreakerCard Card-featuredSquareToRectangleMedia Card-card" data-test="Card"><a href="https://www.cnbc.com/2022/04/28/evercore-isi-says-facebook-is-a-classic-dislocated-high-quality-stock-thats-ridiculously-cheap.html" class="Card-mediaContainer" target="" tabindex="-1"><div class=" "><div class="Card-squareMediaContainer Card-placeholder"><div style="height:100%" class="lazyload-placeholder"></div></div></div></a><div class="Card-textContent"><div class="Card-titleAndFooter"><div><div class="Card-pro"><a href="https://www.cnbc.com/2022/04/28/evercore-isi-says-facebook-is-a-classic-dislocated-high-quality-stock-thats-ridiculously-cheap.html" class="Card-title" target=""><div><a href="/pro/" class="ProPill-proPillLink" data-type="pro-button"><img class="Card-proPill ProPill-proPill" src="data:image/svg+xml;base64,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" alt="CNBC Pro"/></a>Evercore ISI says Facebook is a classic dislocated high quality stock that&#x27;s ridiculously cheap</div></a></div></div><div class="Card-cardFooter Card-bylinePosition"><span class="Card-byline"><a href="https://www.cnbc.com/sarah-min/">Sarah Min</a></span><span class="Card-time">21 min ago</span></div></div></div></div></div><div class="Column-squareLeadRight " data-test="Column"><div class="Card-standardBreakerCard Card-rectangleToRectangleMediaHalf Card-card" data-test="Card"><a href="https://www.cnbc.com/2022/04/28/jpmorgan-says-buy-electric-aircraft-maker-archer-to-play-a-1-trillion-market-opportunity.html" class="Card-mediaContainer" target="" tabindex="-1"><div class=" "><div class="Card-squareMediaContainer Card-placeholder"><div style="height:100%" class="lazyload-placeholder"></div></div></div></a><div class="Card-textContent"><div class="Card-titleAndFooter"><div><div class="Card-pro"><a href="https://www.cnbc.com/2022/04/28/jpmorgan-says-buy-electric-aircraft-maker-archer-to-play-a-1-trillion-market-opportunity.html" class="Card-title" target=""><div><a href="/pro/" class="ProPill-proPillLink" data-type="pro-button"><img class="Card-proPill ProPill-proPill" src="data:image/svg+xml;base64,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" alt="CNBC Pro"/></a>JPMorgan says buy electric aircraft maker Archer to play a $1 trillion market opportunity</div></a></div></div><div class="Card-cardFooter Card-bylinePosition"><span class="Card-byline"><a href="https://www.cnbc.com/sarah-min/">Sarah Min</a></span><span class="Card-time">2 hours ago</span></div></div></div></div><div class="Card-standardBreakerCard Card-rectangleToRectangleMediaHalf Card-card" data-test="Card"><a href="https://www.cnbc.com/2022/04/28/pivotal-downgrades-spotify-says-path-to-profitability-will-require-patience.html" class="Card-mediaContainer" target="" tabindex="-1"><div class=" "><div class="Card-squareMediaContainer Card-placeholder"><div style="height:100%" class="lazyload-placeholder"></div></div></div></a><div class="Card-textContent"><div class="Card-titleAndFooter"><div><div class="Card-pro"><a href="https://www.cnbc.com/2022/04/28/pivotal-downgrades-spotify-says-path-to-profitability-will-require-patience.html" class="Card-title" target=""><div><a href="/pro/" class="ProPill-proPillLink" data-type="pro-button"><img class="Card-proPill ProPill-proPill" src="data:image/svg+xml;base64,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" alt="CNBC Pro"/></a>Pivotal downgrades Spotify, says path to profitability will require patience</div></a></div></div><div class="Card-cardFooter Card-bylinePosition"><span class="Card-byline"><a href="https://www.cnbc.com/sarah-min/">Sarah Min</a></span><span class="Card-time">2 hours ago</span></div></div></div></div></div></div><div class="Button-buttonContainer"><a href="https://www.cnbc.com/pro/street-calls/" class="Button-buttonLink" title="Read More">Read More<span class="icon-arrow-down-readmore TransporterSection-arrowIcon"></span></a></div></div></section></div></div></div><div class="PageBuilder-containerFluidWidths PageBuilder-pageRow"><div class="PageBuilder-col-12 PageBuilder-col PageBuilder-article"><div style="height:100%" class="lazyload-placeholder"></div></div></div></div></div></div></div><div id="MobileAdhesion-Homepage" class="MobileAdhesion-container" data-module="mps-slot"></div><footer class="CNBCFooter-container" id="GlobalFooter" data-mini-video-player-dont-scroll-beyond-here="true" data-test="GlobalFooter" data-analytics="RegularArticle-GlobalFooter"><div class="CNBCFooter-gridContainer"><div class="CNBCFooter-wrapper"><div class="CNBCFooter-header"><a href="//www.cnbc.com"><img src="data:image/svg+xml;base64,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" class="CNBCFooter-logo" alt="logo"/></a></div><div class="CNBCFooter-content"><ul class="CNBCFooter-menu"><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/application/pro/?__source=pro|globalfooter"><div>Subscribe to CNBC PRO</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/cnbc-reprints/"><div>Licensing &amp; Reprints</div></a></li><li class="CNBCFooter-footerOption"><a href="https://www.cnbccouncils.com/" target="_blank"><div>CNBC Councils</div></a></li><li class="CNBCFooter-footerOption"><a href="https://corporate.comcast.com/values/integrity" target="_blank"><div>Supply Chain Values</div></a></li><li class="CNBCFooter-footerOption"><a href="https://www.peacocktv.com/?cid=20200101evergreensymdisp009&amp;utm_source=cnbc&amp;utm_medium=symphony_editorial_brandawareness_footerlink&amp;utm_campaign=20200101evergreen&amp;utm_term=na&amp;utm_content=na_na/" target="_blank"><div>CNBC on Peacock</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/advertising-and-partnerships/"><div>Advertise With Us</div></a></li><li class="CNBCFooter-footerOption"><a href="https://cnbcrsh.qualtrics.com/jfe/form/SV_8v2FqPLC71m5Gaq?Origin=cnbc" target="_blank"><div>Join the CNBC Panel</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/digital-products/"><div>Digital Products</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/cnbc-news-releases/"><div>News Releases</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/closed-captioning/"><div>Closed Captioning</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/corrections/"><div>Corrections</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/about/"><div>About CNBC</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/cnbc-internship-program/"><div>Internships</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/site-map/"><div>Site Map</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/podcast/"><div>Podcasts</div></a></li><li class="CNBCFooter-footerOption"><a href="https://www.nbcuniversal.com/privacy/cookies#cookie_management" target="_blank"><div>Ad Choices</div></a></li><li class="CNBCFooter-footerOption"><a href="//www.cnbc.com/cnbc-careers-and-employment/"><div>Careers</div></a></li><li class="CNBCFooter-footerOption"><a href="https://help.cnbc.com/" target="_blank"><div>Help</div></a></li><li class="CNBCFooter-footerOption"><a href="https://help.cnbc.com/contact/" target="_blank"><div>Contact</div></a></li></ul><ul class="CNBCFooter-share"><li class="CNBCFooter-socialOption"><a href="https://www.facebook.com/cnbc/" target="_blank"><span class="icon-social_facebook"></span></a></li><li class="CNBCFooter-socialOption"><a href="https://www.twitter.com/cnbc/" target="_blank"><span class="icon-social_twitter"></span></a></li><li class="CNBCFooter-socialOption"><a href="https://www.linkedin.com/company/cnbc/" target="_blank"><span class="icon-social_linkedin"></span></a></li><li class="CNBCFooter-socialOption"><a href="https://www.instagram.com/cnbc/" target="_blank"><span class="icon-social_instagram"></span></a></li><li class="CNBCFooter-socialOption"><a href="https://www.youtube.com/user/cnbc/" target="_blank"><span class="icon-social_youtube"></span></a></li><li class="CNBCFooter-socialOption"><a href="https://apple.news/T3OtoXcxtRkuHRkM7SpFP_Q" target="_blank"><span class="icon-social_apple_news"></span></a></li><li class="CNBCFooter-socialOption"><a href="//www.cnbc.com/rss-feeds/" target="_blank"><span class="icon-social_rss"></span></a></li></ul><div class="CNBCFooter-info"><div class="CNBCFooter-section"><h4 class="CNBCFooter-smallHeader">News Tips</h4><p class="CNBCFooter-sectionInfo">Got a confidential news tip? We want to hear from you.</p><a href="//www.cnbc.com/news-tips/"><div class="CNBCFooter-linkButton">Get In Touch</div></a></div><div class="CNBCFooter-section"><h4 class="CNBCFooter-newsletter CNBCFooter-smallHeader"><span class="icon-newsletter CNBCFooter-newsletterIcon"></span><span class="CNBCFooter-newsletterTitle">CNBC Newsletters</span></h4><p class="CNBCFooter-sectionInfo">Sign up for free newsletters and get more CNBC delivered to your inbox</p><a href="//www.cnbc.com/sign-up-for-cnbc-newsletters/"><div class="CNBCFooter-linkButton">Sign Up Now</div></a><p class="CNBCFooter-copyright">Get this delivered to your inbox, and more info about our products and services. </p></div></div><div class="CNBCFooter-privacy"><a href="https://www.nbcuniversal.com/privacy?intake=CNBC" class="CNBCFooter-privacyLink" target="_blank">Privacy Policy</a><span class="CNBCFooter-pipeSymbol">|</span><a href="https://www.nbcuniversal.com/privacy/notrtoo?intake=CNBC" class="CNBCFooter-privacyLink" target="_blank">Do Not Sell My Personal Information</a><span class="CNBCFooter-pipeSymbol">|</span><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=CNBC" class="CNBCFooter-privacyLink" target="_blank">CA Notice</a><span class="CNBCFooter-pipeSymbol">|</span><a href="/nbcuniversal-terms-of-service/" class="CNBCFooter-privacyLink">Terms of Service</a></div><div class="CNBCFooter-disclaimer"><p class="CNBCFooter-copyright">© <!-- -->2022<!-- --> CNBC LLC. All Rights Reserved.<!-- --> <a href="https://www.nbcuniversal.com" target="_blank">A Division of NBCUniversal</a></p><p class="CNBCFooter-copyright">Data is a real-time snapshot *Data is delayed at least 15 minutes. Global Business and Financial News, Stock Quotes, and Market Data and Analysis.</p><div class="CNBCFooter-marketData"><a href="/market-data-terms-of-service/">Market Data Terms of Use and Disclaimers</a></div><p class="CNBCFooter-copyright">Data also provided by<!-- --> <a href="//www.cnbc.com/market-data-terms-of-service/"><img class="CNBCFooter-reutersLogo" src="data:image/svg+xml;base64,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" alt="Reuters"/></a></p></div></div></div></div></footer></div><div class="UniversalVideoPlayer-videoContainer  paused   " style="top:-3000px;bottom:;left:-3000px;transform:;transform-origin:;transition:;position:;transition-property:;opacity:"></div><div class="App-proContentRecommendation"></div></div></div><script charSet="UTF-8">
window._comscore = [];
var EEA_REGION_COUNTRY_CODES = [ "AT", "BE", "BG", "HR", "CY", "CZ", "DK", "EE", "FI", "FR", "DE", "GR", "HU", "IS", "IE", "IT", "LV", "LI", "LT", "LU", "MT", "NL", "NO", "PL", "PT", "RO", "SK", "SI", "ES", "SE", "CH", "TR", "GB" ];
var OneTrustCategories = {
  STRICTLY_NECESSARY: 1,
  TARGETED_ADS: 4,
  STORAGE: 6,
  CONTENT_SELECTION_AND_MEASUREMENT: 7,
  SOCIAL_MEDIA: 8,
}
var initiateComscore = {
  pushData: function(cs_ucfr) {
      var data = {
        c1: '2',
        c2: '1000004',
        options: { url_append: 'comscorekw=PRO_Home_CNBC_Pro' },
        cs_ucfr: cs_ucfr
      };
      window._comscore.push(data);
      initiateComscore.addScripts();
  },

  addScripts: function() {
      (function() {
          var s = document.createElement("script"),
              el = document.getElementsByTagName("script")[0];
          s.async = true;
          s.src = 'https://sb.scorecardresearch.com/beacon.js';
          el && el.parentNode.insertBefore(s, el);
      })();
  },

  getCookie: function(cookieName) {
    return document &&
      document.cookie &&
      document.cookie
        .split(';')
        .map((s) => s.trim())
        .find((s) => s.startsWith(cookieName));
  },

  fetchRegion: function() {
    fetch('https://geo.cnbc.com/info/')
        .then(response => response.json())
          .then(data => {
            if (data && data.geo && data.geo.country_code) {
              if(EEA_REGION_COUNTRY_CODES.includes(data.geo.country_code)) {
                initiateComscore.pushData('0');
              } else {
                initiateComscore.pushData('');
              }
            }
          });
  },

  run: function() {
      if (!Object.values(OneTrustCategories).includes(7)) {
        throw new Error('OneTrust category not found.');
      }
      var optanonCookie = initiateComscore.getCookie('OptanonConsent');
      var usPrivacyCookie = initiateComscore.getCookie('USPrivacy');
      var regionCookie = initiateComscore.getCookie('region');

      // check if regionCookie is present if not fetch region and update cs_ucfr value;
      if (regionCookie) {
        // if region is USA check for USPrivacy Cookie
        if (regionCookie.split('=')[1] === 'USA') {
          var usPrivacyCookieValue = usPrivacyCookie && usPrivacyCookie.split('=')[1];
          if (optanonCookie || usPrivacyCookieValue) {
            if (usPrivacyCookieValue === '1YYN') {
              initiateComscore.pushData('0');
            } else if (usPrivacyCookieValue === '1YNN') {
              initiateComscore.pushData('1');
            } else { // if USPrivacy cookie is not present
              initiateComscore.pushData('1');
            }
          } else {
            initiateComscore.fetchRegion();
          }
        } else {
          // If region is not USA check for OptanonCookie
          if (optanonCookie) {
            var categoryRegex = /groups=[^&]*%2C7%3A([01])/;
            var regexResults = optanonCookie.match(categoryRegex);
            if (regexResults && regexResults[1]) {
              initiateComscore.pushData(regexResults[1]);
            } else {
              initiateComscore.pushData('0');
            }
          } else {
            initiateComscore.fetchRegion();
          }
        }
      } else {
        initiateComscore.fetchRegion();
      }
  }
};
//Run COMSCORE
initiateComscore.run();
</script><noscript><img alt="comscore" src="https://sb.scorecardresearch.com/p?c1=2&c2=1000004&cv=2.0&cj=1" /></noscript><script charSet="UTF-8">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</script><script charSet="UTF-8">
          function isES6Supported() {
            'use strict';

            if (typeof Symbol == 'undefined') return false;
            try {
              eval('class Foo {}');
              eval('var bar = (x) => x+1');
            } catch (e) { return false; }

            return true;
          }

          function addScript(src) {
            var s = document.createElement('script');
            s.setAttribute('src', src);
            document.head.appendChild(s);
          }

          if (!isES6Supported()) {
            addScript('https://static-redesign.cnbcfm.com/dist/polyfill-297c9e9730390b12f0de.js');
          }
        </script><script charSet="UTF-8">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</script></body></html>